Both our LMS and Secure Payments platforms have remained stable following our earlier mitigations, and we are marking this incident as resolved.
By failing over to unaffected AWS Availability Zones, we have isolated LoanPro services from the underlying disruption. All timeout events that occurred during the impact window were reconciled and processed earlier. While AWS continues to work toward full recovery in the affected region, that scope is contained and does not impact LoanPro operations.
We will continue to monitor closely and will reopen this incident if any related impact is observed.
Thank you for your patience.
Posted May 08, 2026 - 00:44 MDT
Update
AWS has reported early signs of recovery in the affected Availability Zone. Additional cooling capacity has come online, allowing AWS to begin recovering affected systems. AWS has committed to a further update by 11:30 PM PDT.
LoanPro services remain stable. Both LMS and Secure Payments continue to operate normally following our earlier mitigations. We will continue to monitor closely.
Posted May 07, 2026 - 23:40 MDT
Monitoring
Both the LMS and Secure Payments platforms are now operating normally.
LMS has been stable for the past 2 hours with no new 504 errors observed. Our Secure Payments platform has also stabilized following our failover to an unaffected AWS Availability Zone.
All timeout events that occurred during the impact window have been reconciled and processed.
The underlying AWS service disruption in us-east-1 remains ongoing. We will continue to monitor closely and post additional updates here if any other LoanPro services are affected.
Posted May 07, 2026 - 23:11 MDT
Update
We are observing increased timeouts within our Secure Payments platform, related to the ongoing AWS service disruption in us-east-1. Current impact is to swipe processing for card transactions and to card updates.
Stand-In Processing (STIP) at the network level means cardholder transactions may continue to be authorized during this period, even where our platform is timing out. Our team is actively monitoring and logging all affected events. Queued updates and reconciliation will be completed automatically once AWS services are restored.
We will continue to post updates here as the situation evolves.
Posted May 07, 2026 - 22:40 MDT
Identified
The ongoing AWS service disruption is now affecting some LoanPro traffic. We are observing an elevated rate of 504 errors on a subset of accounts, related to a thermal event impacting a single Availability Zone in AWS us-east-1.
Much of LoanPro's infrastructure is deployed across multiple Availability Zones. Our engineering team is actively shifting traffic away from the impacted AZ to mitigate customer-facing impact. Error rates have begun to slow over the past hour.
We will continue to post updates here as the situation evolves.
Posted May 07, 2026 - 21:52 MDT
Monitoring
AWS is currently experiencing a service disruption affecting EC2 (us-east-1), CloudFront, Route 53, and other services in their North America region.
LoanPro is not currently impacted and the platform is operating normally. Our team is actively monitoring the situation and will post updates here if our status changes.
Posted May 07, 2026 - 19:54 MDT
This incident affected: LoanPro - LMS Web Application, LoanPro - LMS API, Secure Payments Application, and Connections.