Possible Database Latency
Incident Report for Simnang
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 12, 2018 - 14:44 MST
Monitoring
We are monitoring a situation where some regions are experiencing database latency. It is possible while we remedy the issue that authentication on the login page will be delayed for a few minutes.

No action is necessary on your part.

Regards,
Posted 5 months ago. Jan 12, 2018 - 14:00 MST